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The information in this document reflects products at the date of printing. 
Unitronics reserves the right, subject to all applicable laws, at any time, at 
its sole discretion, and without notice, to discontinue or change the 
features, designs, materials and other specifications of its products, and to 
either permanently or temporarily withdraw any of the forgoing from the 
market. 

All information in this document is provided "as is" without warranty of any 
kind, either expressed or implied, including but not limited to any implied 
warranties of merchantability, fitness for a particular purpose, or non-
infringement. Unitronics assumes no responsibility for errors or omissions 
in the information presented in this document. In no event shall Unitronics 
be liable for any special, incidental, indirect or consequential damages of 
any kind, or any damages whatsoever arising out of or in connection with 
the use or performance of this information. 

The tradenames, trademarks, logos and service marks presented in this 

document, including their design, are the property of Unitronics (1989) 
(R"G) Ltd. or other third parties and you are not permitted to use them 
without the prior written consent of Unitronics or such third party as may 
own them. 
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Creating Project files (Clone files, *.dvi, *.vdf *.urc, *.ura) 
Project files contain application data in compressed format. There are several kinds of 

files. 

 Clone Files: 

These can contain complete applications in compressed format, including Ladder 
and HMI applications and OS. Clone files are very convenient for OEMs, or for 
those wanting to 'Clone' a PLC and its application. These files can be created in 

VisiLogic as well as via SD Clone Ladder functions or in Information mode. 

 Project Files: UniDownloader Designer 

These files include both the Ladder and HMI applications, Data Tables, and an 
Upload file. 
-Standard Vision: .dvi files 

-Enhanced Vision: .vdf 
   Note that the DownLoader files you create here are compatible with 

UniDownloader 4.0.0 and later; provide your users with the correct 
UniDownloader version. 

 Cache files: Remote Access and Remote Operator 

These are compressed HMI Displays. They improve Remote Access reaction 
times, and must be used to display graphic images when using Remote 

Operator. 
- Monochrome Vision (.ura files) 
A .ura cache file enables Remote Operator to load Displays more quickly. Note 

that V130, which loads displays quickly, does not use .ura files.) 
- Colour Vision (.urc files). 

   If a .urc is not used, images are not displayed and fonts may be distorted. 

            A cache file includes fonts, and can include images. If the file does not 
include images, a red 'X' displays in place of graphics. 

To create Project files: 

1. Click on the Project menu and select Create Project files. 

2. Select the appropriate tab and follow the on-screen directions. 



Creating Project files (Clone files, *.dvi, *.vdf *.urc, *.ura) 

 

  

  
Notes ♦  .cxx Files 

  
 PLC Unique ID 

Each PLC has a unique ID number, which is shown in SDW9. Use this 
number to restrict a program to a particular PLC. 

 Password: 
This is assigned to the SD Card via the Set SD Card Password function. 
  

♦  Both the controller you use to make the download file (source), and the 

controller that is installed with the file (target) should be installed with the 
same OS Version. 

♦  To avoid errors in the file, the creation process must run smoothly, without 

being aborted or affected by PC faults. 

   

Checking the integrity of the .dvi file 

Although you do not need to have Remote Access installed on your PC in order to 
create .dvi files, you need to install it in order to check .dvi files. 

1. After you have created the .dvi file, save the project from which it was 
downloaded. 

2. Open a new, empty project and download it to the controller. 

3. Start Remote Access and select the appropriate Vision model. 

4. Click on the Project Downloader which is located on the Remote Access 
Tools menu. 

5. Navigate to the .dvi file and download it into the controller.   
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6. Reopen the original Ladder project used to create the .dvi file. 

7. Select Verify from the Controller menu; the Verify process will compare 
the project in your PC with the .dvi application installed in the controller. 

If the Verify process is successful, the .dvi file is valid. 

UniDownloader Designer 

The UniDownloader package enables you to build a complete, compressed project 
and send it anywhere to be installed in a PLC using a standalone downloader. Your 

end user will be able to download the application, but will not be able to view or 
modify it. The tool can download applications and OS. 

The package comprises the UniDownload Designer, located on the Tools menu, and 

the UniDownloader, available as a separate download from www.unitronics.com. 

To learn about UniDownloader, click on the Tools menu in VisiLogic, U90 Ladder, or 

Remote Access, select UniDownloader Designer, and then access the UniDownloader 
Designer Help. 
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Send e-mail attachments 
Note the Attach field; Enhanced Vision controllers with SD cards enable you to attach a 

file from the SD card. Note that the file name must adhere to the 8.3 file format. 
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SD: Cloning via Ladder 
SD Clone functions can: 

 Create compressed data files and store them on an SD card. 

 Upload compressed files from an SD card to a PLC. 

You can 'clone' a complete PLC or data using the SD Ladder functions 

These Ladder functions are parallel to the actions you can carry out via Information 
Mode. 

Note ♦  You can use Unitronics' SD Card Explorer, included in the SD Card Suite, to 
access SD card files and either upload them to a PC for viewing and editing, or 

transfer them into another PLC's SD card. 

  

This function must be used with a negative transition element. 

 

  

Parameter Purpose 

Direction Clone To SD: Creates a compressed data file in the correct SD card folder 
Clone From SD: Installs a compressed data file from an SD card folder into the PLC 

File Type Select Direct or Constant. 
If you select Direct, the value in the register determines the data file that the function 

creates/installs according to the following legend: 
  2 = Full Data Table (*.fdt files) 
  4 = Firmware (*.Oxx files: .O13, .O35, or .O57) 
  5 = User Application (+VLP if exists) (*.vxx files: .V13, .V35, .V57) 
  7 - Full cloning (DT, Firmware, UA, Operands)(*.Cxx) .C13, .C35, or C57) 
  8 = Operands (*.Dxx files: .D13, .D35, .D57) 

Note that the file extension numbers relate to the Vision model: .x13 =V130, .x35 =V350, 

.x57 =V570 

File Name This is limited to 8 characters. The file extension is automatically assigned by the PLC 
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according to the file type. 

 If you are cloning an OS or a ‘Full Clone’, the file name MUST be exactly 8 characters 

long. 

Status This MI is a bitmap; a bit turns ON to indicate status. 
The MI is initialized when the function starts. 
  

 All bits OFF – No errors, and the process is idle 

 Bit 1 –  No SD card found, or the card is locked (Write-enable OFF) 

 Bit 2 – Clone utility busy 

 Bit 3 -File type not found (*.FDT,*.Oxx,*.Vxx,*.Dxx,*.Cxx) 

 Bit 4– Incompatible Boot Version/Firmware/Clone file 

 Bit 5 - Internal use 

 Bit 6- Timeout exceeded 

 Bit 7 - - Safe to Remove Bit is ON 

 Bit 8 - Path not found (Install Clone) 

 Bit 9 - Password error 

Success Bit 
  

Turns ON when the data is successfully written to the SD. It remains ON until it is reset by 
the application, or until the application calls the function. 

  

SB 366: Clone in Progress. Note that he process can take from several seconds to 
several minutes) 

The following nets show the conditions required to run the function. 
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SD: Safely Remove 
Use SD: Safely Remove to prevent the card from being physically removed while an SD 

function is in progress. 

When SD: Safely Remove is called, it: 

 Checks to see if any SD functions are running. 

 If so, Safe to Remove indicates which function is active via the Status DW. 

 It allows a current task to be completed, but prevents new ones from starting. 

When the SD card is completely free, the Safe to Remove bit turns ON. This must be 
reset by the user. 

The following image shows the Log> SD Success MB used in conjunction with the SD: 
Safely Remove function. 

 

  

The Status DW is a bitmap. 
Bits and their indications are shown in the following table. When a bit is ON, the related 

function is active. 

Bit Function 

0-5 (reserved)   

6 Start Saving to SD is running: SD Trend 8 

7 Start Saving to SD is running: SD Trend 7 

8 Start Saving to SD is running: SD Trend 6 

9 Start Saving to SD is running: SD Trend 5 

10 Start Saving to SD is running: SD Trend 4 

11 Start Saving to SD is running: SD Trend 3 
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12 Start Saving to SD is running: SD Trend 2 

13 Start Saving to SD is running: SD Trend 1 

14 HMI function Trend from SD 

15 SD File Info 

16 Delete SD File 

17 Folder Report: Number of Files 

18 Create Excel Delimited Line 

19 SD File Utilities: SD File Write 

20 SD File Utilities: SD File Read 

21 SD Block Utilities: Read/Write to Block 3 

22 SD Block Utilities: Read/Write to Block 2 

23 SD Block Utilities: Read/Write to Block 1 

24 SD Block Utilities: Read/Write to Block 0 

25 HMI Variable SD Browser 

26 PC Utility is communicating with SD 

27 Information Mode is accessing SD 

28 SD Data Table Utilities: Log DT Row 

29 SD Data Table Utilities: Read from DT /Search DT for Tag or Index 

30 SD Data Table Utilities: Write to DT 

31 Alarm History is being logged to SD 
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SNMP: Trap and Community Name 
  

SNMP Trap 

In addition, the Vision can send Trap messages in response to Ladder conditions, via the 

function COM>TCP/IP>SNMP Trap. 

The PLC supports integer values, strings, and null. 

 

Parameter Purpose 

Socket Select any socket 

IP: Target 

device 

The operand value will be sent to this IP 

Trap ID Use this to assign an SNMP number to the device 

Trap Operand This is the operand that is sent to the target device. If the data sent is a string, the Trap 

operand is the start of a vector; the PLC will send data from the vector until it reaches a 

null. 

Trap Format Select integer, string, or null 

SNMP Trap 
Status: 

 0: Valid trap. 

 1: Invalid port (the Rx socket is not Port 161) 

 2: The destination IP is in an invalid format 

  

SNMP Community Name 

Use this function to assign the controller a name, enabling it to be accessed via SNMP. 
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Telegram Parser 
This function parses data sent to a vector of operands. You can use this function in 

conjunction with FB Protocol to parse messages. 
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String Library: Strings to/from Excel or .csv 
These tools are located on the String Library File menu. 

 
  

Excel: you cannot create an Excel file and import it. You must export a String 
Library from a String Library, delete any undesired information, and then enter 

your own strings. 

  .csv: you must use a delimiter that does not appear within the string's data, or 
the values will not be separated according to expectations. 

  

Import/Export from Excel 

1. Select all of the Strings in a Library. and then select Export 
 

 
  

2. From the File menu, select Export to Excel. 
 

 
 
  

3. Open and edit the Library, and then import it into any Library. 

Linking HMI Elements to Text in a String Library 

1. Place a Frame, Button, or Fixed Text HMI element. Within the element properties, 
click the String from String Library option. 



VisiLogic 8.6.0—Help Highlights 

i4 Automation Ltd  May 2010 

 

You can either link a Text ID line directly, or use an MI to indirectly provide the 
Text line ID. 

Note that the size of the HMI element must be large enough for the longest text 

line it may hold. 

 

  

Switching Libraries 

To switch Libraries, use one of these methods: 

 Use the Ladder function Strings>Set String Library 

 Write a value to SI 491 Switch current Text Library 
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Project Optimizer 
Run the Optimizer to view a list of possible improvements that you can make in your 

project. In the results window, double click a line to jump to the appropriate location in 
the project. 
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Digital Signatures 
View Digital Signatures by clicking the View menu and selecting Show Signature Log. 

This  project security feature can enable Vision PLCs to meet standards in niche 
industries such as pharmaceuticals. The log: 

  Records changes made in a project. 

 

  Tracks the last projects downloaded to a PLC.  

 

  Enables you to save the signature log within a VisiLogic project.  
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Digital Signatures 

 

  Compares the signature of the project to the signature of the last project that was 

downloaded to the PLC. 
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HMI Display Bit 

You can link an MB which will be ON while the Display is shown on screen, or an XB 
which will change status. 
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